Jump to content

Recommended Posts

Clutched (edited)

thanks for the advice. :D and mandrew

Edited by Human

Share this post


Link to post
Share on other sites
Neutral Newbie

any Exora Bold owner who prefer to use CPS tail light and wishes to swap. Please PM me lor.

i willing to top up [:p]

 

 

Share this post


Link to post
Share on other sites
Neutral Newbie

Anyone interested in replacing their rear reflector to a brake light. Do PM me. I bought it but yet to fix.

Still in packaging.

 

Nasiroo, enjoy ur new gadget. I assume u get it from bro mandrew.

Share this post


Link to post
Share on other sites

My handbrake sensor light is On even after releasing handbrake and during driving. Any advise on the problem and any workshop to check? [:(]

Share this post


Link to post
Share on other sites

wow...so much problems....mine is so far so good...

Share this post


Link to post
Share on other sites
Supercharged

My handbrake sensor light is On even after releasing handbrake and during driving. Any advise on the problem and any workshop to check? [:(]

Check your brake fluid....see if any leak.

 

And when you step on brake pedal, is it still effective?

 

Share this post


Link to post
Share on other sites

Check your brake fluid....see if any leak.

 

And when you step on brake pedal, is it still effective?

 

Everything is okay. Looks like sensor or some other thing. Have to go workshop to check.

Share this post


Link to post
Share on other sites

Just came from Genting trip.

The trip was very smooth....

Was able to enjoy the difference of the CFE engine while climbing the Genting highlands.

Last year I went to Genting in my CPS and could really feel the strain while climbing.

 

This time my Bro-in-law also joined me with his 5yr old 2lt Toyota Picnic with the same load of 5 adults.

He was sharing that he had to always lower the gear(in his auto gear) and then also cannot keep up with my car (certainly not speeding.. we were always keeping the road speed limit). And at certain places I had to stop and wait for him to join.

Sorry, not trying to say bad about Picinic here.... that's also a nice car... maybe one diffrence is due to the 5yr old... but CFE is good :)

 

One issue I noticed for the CFE is about the Brakes.

"Please take special care while driving down after leaving the car in extreme Cold conditions..."

Left the car in the open car park for about 2 and a half days. The weather was very cold and misty almost throughout the day.

When I started itself I realised that the brakes are very less. I pumped a few times then also no much differences.

So I decided to take a round in the Top hill itself before driving back and was applying the brake frequently... until it was back to normal.

Pls see whether any of you have similar experiences...

The CPS didin't have this issue. One difference in CFE is that all are Disc brakes...

 

Wishing all a Happy and Prosperous New Year in advance!

Share this post


Link to post
Share on other sites
Clutched

Everything is okay. Looks like sensor or some other thing. Have to go workshop to check.

 

 

My problem is the ABS light, after 60K major service in my hometown, the light kept lid. sent in to local workshop and had the system reset. the light goes off for awhile but came back when i applied the brake.

 

any suggestion is much appreciative.

Share this post


Link to post
Share on other sites
Clutched (edited)

I checked the brake and clutch fluid and its almost empty. Top up with mobil dot 4 (small box) and voila the handbrake sensor is gone. Rechecked and no leaking [sweatdrop] phew

 

Suspect that the previous 2 servicing the guy forgot to top up but there's no proof - just a hunch though.

Edited by Noirmubin

Share this post


Link to post
Share on other sites
Clutched (edited)

My problem is the ABS light, after 60K major service in my hometown, the light kept lid. sent in to local workshop and had the system reset. the light goes off for awhile but came back when i applied the brake.

 

any suggestion is much appreciative.

 

Mine got same problem during yr 2011 - mileage 42k. Went to JB Proton and showed me sensor worn out and replaced with new one with 6 months warranty. Cost me ringgit 900 (about there) [bigcry] the sensor is at the top right corner if you open the bonnet

 

For the handbrake sensor light - try to check the brake fluid

 

The car's all fine now...top up with shell 95 here in sg and very light and responsive. I find using Esso feel heavy

 

Edited by Noirmubin

Share this post


Link to post
Share on other sites
Supercharged

I checked the brake and clutch fluid and its almost empty. Top up with mobil dot 4 (small box) and voila the handbrake sensor is gone. Rechecked and no leaking [sweatdrop] phew

 

Suspect that the previous 2 servicing the guy forgot to top up but there's no proof - just a hunch though.

Bro, does brake fluid need to top-up? I tot it is a closed system....

 

I am surprised you could still brake properly when your fluid is almost empty.... [laugh]

↡ Advertisement

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×