Jump to content
Sign in to follow this  
Gorjiam

Alfa 159 Part VIII (Any Alfa discussion also welcomed)

Recommended Posts

By the powers bestowed onto me, I shall declare this.. A NEW THREAD!

Carried on from here:

http://www.mycarforum.com/topic/2689190-alfa-159-part-vii-any-alfa-discussion-also-welcomed/page-76

↡ Advertisement
  • Praise 1

Share this post


Link to post
Share on other sites

just wanna check if anyone experienced it. occasionally i have difficulties in starting the engine. after inserting car key for a few second then press start button, its doesnt crank, but with a tick sound. at times i got to press a few times then it will crank and start the engine, other time i can start once i push the start button. battery changed few months ago.

 

my question is whether there is any known issue? was it an indication of starter motor going to kaput soon? or was it my remote key battery failing thus failing to initialize the immobiliser? or anything im not aware of.

Share this post


Link to post
Share on other sites

just wanna check if anyone experienced it. occasionally i have difficulties in starting the engine. after inserting car key for a few second then press start button, its doesnt crank, but with a tick sound. at times i got to press a few times then it will crank and start the engine, other time i can start once i push the start button. battery changed few months ago.

 

my question is whether there is any known issue? was it an indication of starter motor going to kaput soon? or was it my remote key battery failing thus failing to initialize the immobiliser? or anything im not aware of.

 

 

Mine was due to the battery last time. I change the battery and it goes away.

 

But you said u change the battery, I guess other's can advice you better.

 

So far my car Key battery is still ok for more then 4 years plus, how long is your car key battery?

 

 

 

 

To Saabretooth and thingy:

 

Sent to the workshop and primary diagnostic was that my selespeed clutch needs to be change and my driveshaft there is some problem on the right hand side.

 

Normally what mileage does the clutch need to be change?

Edited by Flameblade
↡ Advertisement

Share this post


Link to post
Share on other sites

just wanna check if anyone experienced it. occasionally i have difficulties in starting the engine. after inserting car key for a few second then press start button, its doesnt crank, but with a tick sound. at times i got to press a few times then it will crank and start the engine, other time i can start once i push the start button. battery changed few months ago.

 

my question is whether there is any known issue? was it an indication of starter motor going to kaput soon? or was it my remote key battery failing thus failing to initialize the immobiliser? or anything im not aware of.

Use metal key got

Same

Problem?

 

 

Sent to the workshop and primary diagnostic was that my selespeed clutch needs to be change and my driveshaft there is some problem on the right hand side.

 

Normally what mileage does the clutch need to be change?

 

Think is driving habit rt?

Say if u keep using the launching technique...

Share this post


Link to post
Share on other sites

Had a scare today. Lane 2 at CTE tunnel. Gear 5 and cruising. D+S.

 

 

Car revved up and switched to N with gear stick still at right position.

 

Flicked left and right...no response.

 

Switched Sport mode off.. no response.

 

Put D off.. no response.

 

Switched back and forth about 5x.. no response.

 

Put hazard light and wanted to switch to the left lane but stupid big truck just die die want to travel parallel with me, preventing me from going over. By then speed was like 60kmh liao

 

Tried frantically again..finally managed to get in gear.

 

 

What a good scare.

Edited by Theoldjaffa

Share this post


Link to post
Share on other sites

 

 

Mine was due to the battery last time. I change the battery and it goes away.

 

But you said u change the battery, I guess other's can advice you better.

 

So far my car Key battery is still ok for more then 4 years plus, how long is your car key battery?

 

 

 

 

 

To Saabretooth and thingy:

 

Sent to the workshop and primary diagnostic was that my selespeed clutch needs to be change and my driveshaft there is some problem on the right hand side.

 

Normally what mileage does the clutch need to be change?

Clutch is a wear and tear part. It's like buying running shoe and use for walking. How long can it last?

How about if it's used by a marathon runner?

 

Not trying to be funny here.

But usually 50 to 75k is about there unless you're driving miss daisy

Drive shafts can refurbished but life span is shorter. Maybe 20 to 25k

Share this post


Link to post
Share on other sites

Clutch is a wear and tear part. It's like buying running shoe and use for walking. How long can it last?

How about if it's used by a marathon runner?

 

Not trying to be funny here.

But usually 50 to 75k is about there unless you're driving miss daisy

Drive shafts can refurbished but life span is shorter. Maybe 20 to 25k

 

 

Wear and tear I understand.

 

My mileage is around 95K ... the workshop was telling me people change around 50 - 60,000 KM, got one extreme case is change at 30,000.

 

So I guess mine is reasonable, I was planning to do a major maintenance to change all the worn out parts one shot when I hit 100,000 KM.

Share this post


Link to post
Share on other sites

 

 

Wear and tear I understand.

 

My mileage is around 95K ... the workshop was telling me people change around 50 - 60,000 KM, got one extreme case is change at 30,000.

 

So I guess mine is reasonable, I was planning to do a major maintenance to change all the worn out parts one shot when I hit 100,000 KM.

 

 

 

You're just about right on time then :)

 

for me, I have to change clutch every 50-60k, with great power comes great responsibility... ....

Share this post


Link to post
Share on other sites

Had a scare today. Lane 2 at CTE tunnel. Gear 5 and cruising. D+S.

 

 

Car revved up and switched to N with gear stick still at right position.

 

Flicked left and right...no response.

 

Switched Sport mode off.. no response.

 

Put D off.. no response.

 

Switched back and forth about 5x.. no response.

 

Put hazard light and wanted to switch to the left lane but stupid big truck just die die want to travel parallel with me, preventing me from going over. By then speed was like 60kmh liao

 

Tried frantically again..finally managed to get in gear.

 

 

What a good scare.

Mine today also had some sort of gearbox operation issue. Check gear box warning. Unable to reverse or shift up above 3rd gear in auto or manual. After I arrive destination I restart then goes back normal.

Share this post


Link to post
Share on other sites

just wanna check if anyone experienced it. occasionally i have difficulties in starting the engine. after inserting car key for a few second then press start button, its doesnt crank, but with a tick sound. at times i got to press a few times then it will crank and start the engine, other time i can start once i push the start button. battery changed few months ago.

 

my question is whether there is any known issue? was it an indication of starter motor going to kaput soon? or was it my remote key battery failing thus failing to initialize the immobiliser? or anything im not aware of.

Maybe car battery or key battery. Is this happening more and more or?

Share this post


Link to post
Share on other sites

Hi,

 

I'm looking for the rear muffler for the 159 2.2 JTS (Both sides). You guys have any lobang on where i can get a used one?

 

Thanks and regards

Mig

Share this post


Link to post
Share on other sites

Mine today also had some sort of gearbox operation issue. Check gear box warning. Unable to reverse or shift up above 3rd gear in auto or manual. After I arrive destination I restart then goes back normal.

 

FYI:

I have the gear unable to shift abv 3 twice, but can reverse.

both times download point to brake switch.

only resetted the software and gd to go. didn't chg the brake switch.

Share this post


Link to post
Share on other sites

Mine today also had some sort of gearbox operation issue. Check gear box warning. Unable to reverse or shift up above 3rd gear in auto or manual. After I arrive destination I restart then goes back normal.

Bro I had this issue a month back.. Mine gear sensor kaput.. Hope urs nt this cos it's kinda ex to change

Share this post


Link to post
Share on other sites

Mine today also had some sort of gearbox operation issue. Check gear box warning. Unable to reverse or shift up above 3rd gear in auto or manual. After I arrive destination I restart then goes back normal.

Better go get it checked. I had the same message that went away after restart, so I thought nothing of it.

 

My Bella rewarded me with a trip up the tow truck about a month later.

 

I notice my gearbox is leaking oil again. Gonna get it fixed real soon.

Share this post


Link to post
Share on other sites

Maybe car battery or key battery. Is this happening more and more or?

its intermittent, just machiam PMS lei. Happy start without problem, bad mood, press 3-4 times then can start....argghhh

 

i changed to my spare key also the same...zzz

 

could it be sensor problem? our ride need either depress clutch or brake pedal in order to start, so could it be the sensor that unable to detect at time?

Use metal key got

Same

Problem?

huh? how to use metal key to start car? zzz. im lost

Share this post


Link to post
Share on other sites

Simplebay, after you sort out the bugs, I found something that might interest you.... :)

 

How does 290hp and 355Nm sound to you?

↡ Advertisement

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×