Jump to content

My subaru impreza for track racing version


Recommended Posts

I would like to say hi to everyone in this forum and here is a piece of my Subaru impreza for track racing version which I had used it to race for the time attack at the local international circuit before for sure to be honest with you there.The car comes with the yellow shade light weight sport rims and carbon fiber double layers wing there.Please check it out on the scans below and let me know what you think there.Thank you

 

 

image.jpg

image.jpg

image.jpg

image.jpg

image.jpg

image.jpg

image.jpg

image.jpg

image.jpg

image.jpg

image.jpg

↡ Advertisement
  • Praise 5
Link to post
Share on other sites

It is nice to hear that from you and agree what you have commented there but its not important anymore because I have sold this show piece normal sti version after enough of tracing racing and keeping the limited edition after my own decision for the vehicle which I have sold is without rear spoiler because its rare enough and store in my house for the future purpose usage to make everything clear to you.

  • Praise 2
Link to post
Share on other sites

Yesterday on my way back to SG on NSHW, I was playing with an Audi S5 with my 09 WRX hatch. Traffic was rather busy. I full throttled on top gear at around 110km/h to overtake, the car suddenly jerked violently after which CEL on. Crawl abt 30km back to JB. Had dinner, pumped petrol, jammed for nearly an hr before I went toilet at ICA woodlands. Restart car, CEL gone! Anyone know what could be the likely reason?

  • Praise 2
Link to post
Share on other sites

Yesterday on my way back to SG on NSHW, I was playing with an Audi S5 with my 09 WRX hatch. Traffic was rather busy. I full throttled on top gear at around 110km/h to overtake, the car suddenly jerked violently after which CEL on. Crawl abt 30km back to JB. Had dinner, pumped petrol, jammed for nearly an hr before I went toilet at ICA woodlands. Restart car, CEL gone! Anyone know what could be the likely reason?

 

Sounds like a worn out coil.

  • Praise 1
Link to post
Share on other sites

Yesterday on my way back to SG on NSHW, I was playing with an Audi S5 with my 09 WRX hatch. Traffic was rather busy. I full throttled on top gear at around 110km/h to overtake, the car suddenly jerked violently after which CEL on. Crawl abt 30km back to JB. Had dinner, pumped petrol, jammed for nearly an hr before I went toilet at ICA woodlands. Restart car, CEL gone! Anyone know what could be the likely reason?

Hit boost limit.

Check if the code is p0244

  • Praise 1
Link to post
Share on other sites
(edited)

Hit boost limit.

Check if the code is p0244

 

That's what I think too. Lucky cut off otherwise turbo sure piang! Bringing the car to my tuner this weekend for a check.

Edited by Aaronlkl
  • Praise 3
Link to post
Share on other sites

Yesterday on my way back to SG on NSHW, I was playing with an Audi S5 with my 09 WRX hatch. Traffic was rather busy. I full throttled on top gear at around 110km/h to overtake, the car suddenly jerked violently after which CEL on. Crawl abt 30km back to JB. Had dinner, pumped petrol, jammed for nearly an hr before I went toilet at ICA woodlands. Restart car, CEL gone! Anyone know what could be the likely reason?

 

LoL...the computer must have cut the boost to protect the engine. Just stop by the roadside, turn off ignition, open the door. Wait a few seconds and restart. Must be funny kinda feeling running the car on NA w/o the turbo?

  • Praise 1
Link to post
Share on other sites

 

LoL...the computer must have cut the boost to protect the engine. Just stop by the roadside, turn off ignition, open the door. Wait a few seconds and restart. Must be funny kinda feeling running the car on NA w/o the turbo?

 

Yes bro, not boosting at all after CEL. its sucks!

  • Praise 1
Link to post
Share on other sites

Wait. CEL come on you continue to drive another 30km ???


Whats your tuner's name ? Could be the same clown as mine who set my boost limit too low.

  • Praise 1
Link to post
Share on other sites

Wait. CEL come on you continue to drive another 30km ???

 

 

Whats your tuner's name ? Could be the same clown as mine who set my boost limit too low.

 

Ya. I crawl back. No choice to dangerous to stop anywhere on busy NSHW.. I PM u his name. Not too good to post here.

  • Praise 2
Link to post
Share on other sites

Sounds like car experienced major knock and went into limp mode. Happened to me once due to running out of meth while at full bore in the hills between pagoh-machap.

 

 

 

Looking at OP's car, I wonder why the "track racing" car got no rollcage.

  • Praise 1
Link to post
Share on other sites

Yesterday on my way back to SG on NSHW, I was playing with an Audi S5 with my 09 WRX hatch. Traffic was rather busy. I full throttled on top gear at around 110km/h to overtake, the car suddenly jerked violently after which CEL on. Crawl abt 30km back to JB. Had dinner, pumped petrol, jammed for nearly an hr before I went toilet at ICA woodlands. Restart car, CEL gone! Anyone know what could be the likely reason?

 

 

ahaha you can ask aarontyb mah :P

 

Ya. I crawl back. No choice to dangerous to stop anywhere on busy NSHW.. I PM u his name. Not too good to post here.

pm me too bro

  • Praise 1
Link to post
Share on other sites

 

 

ahaha you can ask aarontyb mah :P

pm me too bro

 

I did. The 1st thing I return home is whatsapp aarontyb. He guessed the jerk could hv been the E throttle suddenly sensing the signal to open full but couldn't react as fast as my foot.. U experienced this before?

  • Praise 3
Link to post
Share on other sites
Turbocharged

Those are some sick pictures man, your photographer did the car justice. Sweet Ex ride too btw.

 

I would like to say hi to everyone in this forum and here is a piece of my Subaru impreza for track racing version which I had used it to race for the time attack at the local international circuit before for sure to be honest with you there.The car comes with the yellow shade light weight sport rims and carbon fiber double layers wing there.Please check it out on the scans below and let me know what you think there.Thank you

 

 

 

 

 

 

 

 

  • Praise 2
Link to post
Share on other sites

Sounds like car experienced major knock and went into limp mode. Happened to me once due to running out of meth while at full bore in the hills between pagoh-machap.

 

 

Did the knock cause any damage to ur ride?

  • Praise 5
Link to post
Share on other sites
(edited)

Rear track looks narrow.

STi should have headlight washer?

V-Lip missing STi emblem.

Looks like just another JDM AutoRex.

Agree..looks like JDM 2.0L Auto

But i think this ride is very swee…i like..simple simple, outlook dun need to be loud…

May i know what tyre size?

Edited by Cj12329
  • Praise 2
Link to post
Share on other sites

 

I did. The 1st thing I return home is whatsapp aarontyb. He guessed the jerk could hv been the E throttle suddenly sensing the signal to open full but couldn't react as fast as my foot.. U experienced this before?

Yup experienced before but surprisingly never throw any check light

↡ Advertisement
  • Praise 2
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...