Jump to content
Johny_walker

IRoad In-Car Camera Recorder Users

Recommended Posts

I've BlackVue on the front windscreen. Isit necessary to install another set at the rear just incase someone kiss your bumper and you've solid proof to show your insurance for damages claim.
Anyone done before?

↡ Advertisement
  • Praise 4

Share this post


Link to post
Share on other sites

I've BlackVue on the front windscreen. Isit necessary to install another set at the rear just incase someone kiss your bumper and you've solid proof to show your insurance for damages claim.

Anyone done before?

 

Some people say actually rear camera more important than front camera.

 

I would say it's best to have both judging by the way people are driving on the road these-days. Leave no areas to be disputed.

  • Praise 3

Share this post


Link to post
Share on other sites

I've BlackVue on the front windscreen. Isit necessary to install another set at the rear just incase someone kiss your bumper and you've solid proof to show your insurance for damages claim.

Anyone done before?

 

Many have done that... best is to have cams covering all sides...

 

  • Praise 3

Share this post


Link to post
Share on other sites

Hi all,

 

Wonder if anyone using this brand of car camera. Any user review?

  • Praise 4

Share this post


Link to post
Share on other sites

IRoad user here :D

Anything you will like to know? :)

↡ Advertisement
  • Praise 4

Share this post


Link to post
Share on other sites

iRoad User too.

previously a V7 user, now a V9.

V7 is a very good cam but upgrade to the V9 becos of FHD.

No regrets.

  • Praise 3

Share this post


Link to post
Share on other sites

iRoad User too.

previously a V7 user, now a V9.

V7 is a very good cam but upgrade to the V9 becos of FHD.

No regrets.

 

bro, you used v7 for how long before changing to v9?

currently me on v7 for around 8 months.

  • Praise 2

Share this post


Link to post
Share on other sites

 

bro, you used v7 for how long before changing to v9?

currently me on v7 for around 8 months.

 

 

I bought V7 during Sitex Nov 2014 and has used it till Jun this year.

I bought the V9 Pre Launch Sale during IT Show Mar 2015 while shopping for a laser printer. I only got to install it during Jun as they has just launched the cam.

  • Praise 3

Share this post


Link to post
Share on other sites

Im currently on v7.. Pretty good so far.. Hot hot under sun also working well. Resolution wise still clear during daylight. Love the wifi function.. Easy to operate and save videos

  • Praise 4

Share this post


Link to post
Share on other sites

 

 

I bought V7 during Sitex Nov 2014 and has used it till Jun this year.

I bought the V9 Pre Launch Sale during IT Show Mar 2015 while shopping for a laser printer. I only got to install it during Jun as they has just launched the cam.

 

Hi hi,

 

Does the V9 uses the same cable as V7 or we need to re-run the cables as well? (e.g. plug and play to switch from V7 to V9 without cable change)

 

Thanks.

  • Praise 4

Share this post


Link to post
Share on other sites

Will the iRoad cam be able to withstand the heat and operate normal when a car is parked under the hot sun for the whole day?

  • Praise 3

Share this post


Link to post
Share on other sites

v7 users - does ur motion detect during parking work?

 

mine seem to record non stop so now I jus unplug it totally.

 

about 6+mths usage.

  • Praise 3

Share this post


Link to post
Share on other sites

v7 users - does ur motion detect during parking work?

 

mine seem to record non stop so now I jus unplug it totally.

 

about 6+mths usage.

 

Mine same...

 

thought they were to fix it with some update?

  • Praise 4

Share this post


Link to post
Share on other sites

 

Mine same...

 

thought they were to fix it with some update?

 

ok thk I wil call my installer and wil update...been dragging my feet on this for easily 3mths & counting haha..

Share this post


Link to post
Share on other sites

 

Hi hi,

 

Does the V9 uses the same cable as V7 or we need to re-run the cables as well? (e.g. plug and play to switch from V7 to V9 without cable change)

 

Thanks.

Hi,

I think only the rear cable of V7 & V9 is different.

Hope that helps...

  • Praise 2

Share this post


Link to post
Share on other sites

 

ok thk I wil call my installer and wil update...been dragging my feet on this for easily 3mths & counting haha..

 

I have been using V9 for 3 weeks. No experience with V7. Prior to buying V9, I wrote in through their website asking about V7 motion detect problem and whether V9 will have the same problem. The friendly Korean customer support replied as follows:

 

"V7 and T8 have sensitive detection sensors in there, which detect even small motions and light. We usually recommend customers to adjust the setting of sensitivity low and most of cases have been fine. V9 is the latest model which was considered some advises from consumers. So, It will be fine for V9 on this matter. "

 

So, please try changing the sensitivity setting to low if you are V7 users. I also read a lot forum users said a fix will be released bla bla bla .. not sure if there will ever be if it is a hardware design fault or if they want to promote newer model.

 

V9 confirmed don't have the problem.

  • Praise 4

Share this post


Link to post
Share on other sites

For V7, If I turn off the impact and parking mode, only turn on motion. What mean har??

For V7, If I turn off the impact and parking mode, only turn on motion. What mean har??

  • Praise 3

Share this post


Link to post
Share on other sites

 

I have been using V9 for 3 weeks. No experience with V7. Prior to buying V9, I wrote in through their website asking about V7 motion detect problem and whether V9 will have the same problem. The friendly Korean customer support replied as follows:

 

"V7 and T8 have sensitive detection sensors in there, which detect even small motions and light. We usually recommend customers to adjust the setting of sensitivity low and most of cases have been fine. V9 is the latest model which was considered some advises from consumers. So, It will be fine for V9 on this matter. "

 

So, please try changing the sensitivity setting to low if you are V7 users. I also read a lot forum users said a fix will be released bla bla bla .. not sure if there will ever be if it is a hardware design fault or if they want to promote newer model.

 

V9 confirmed don't have the problem.

Tks for the above bro. Prob tom morning I try the sensitivity thing n see if it solves the prob.

↡ Advertisement

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×