Jump to content
Sdf4786k

New Renault Megane - very 3 series

Recommended Posts

Bro, Congrats on your new ride !! Just sharing my experience in CS2 titanium coating. I done my titanium coating back in March. In July it shinningness started to wear off a little especially on the bonnet. You can see the differences. Although it said it doesn't need any maintenance for 3 years , you should sent in for claybar wash ($20) once in 2-3 months. I washed my car in petrol station weekly. since i sent in my car for the claybar in July, the shinningness came back like brand new car.

 

Thanks Kasiao for the info. I will monitor. They have given a warranty with the shine level. According to the warranty, if the shine level drops below the reading that they took, they will polish it up again. and if there are any stubborn stains they will also remove it for you. the warranty is void if its due to an accident or if its caused by something acidic. 

↡ Advertisement
  • Praise 1

Share this post


Link to post
Share on other sites

Feel good faith plays a BIG part in such "warranties".

 

Acidic pretty much covers the usual causes.. bird droppings, plant sap, even rainwater.

 

So...

Share this post


Link to post
Share on other sites

Feel good faith plays a BIG part in such "warranties".

 

Acidic pretty much covers the usual causes.. bird droppings, plant sap, even rainwater.

 

So...

 

Keeping my fingers crossed. But as one of my close friend knows the owner, my confidence is good. 

Share this post


Link to post
Share on other sites

Sedan 1.5 Privilage. Diesel

Me too.. LOL.

 

Tried RLink2 last evening. Supposedly "mandatory" update.. did that but dun see any difference.

 

Map as installed for navigation seems rather outdated but no update for SG/MY.. only Europe.

Share this post


Link to post
Share on other sites

Me too.. LOL.

 

Tried RLink2 last evening. Supposedly "mandatory" update.. did that but dun see any difference.

 

Map as installed for navigation seems rather outdated but no update for SG/MY.. only Europe.

I was looking at my RLink2 yesterday. My connect button is not enabled. So is my AppStore button. Did you have to do anything to get it enabled?

↡ Advertisement

Share this post


Link to post
Share on other sites

thats quite unfortunate.

 

Probably the price point and the low demand from buyers.

 

Performance at 8.6 sec for zero to 100 is consider a warm hatch.

Should be well below 8s. A sylphy with same engine tuned to lower power is already 8.4s.

Share this post


Link to post
Share on other sites

I was looking at my RLink2 yesterday. My connect button is not enabled. So is my AppStore button. Did you have to do anything to get it enabled?

Couldn't get them enabled...

 

Seems like they need access to data service but no guide how to set that..

Share this post


Link to post
Share on other sites

Keeping my fingers crossed. But as one of my close friend knows the owner, my confidence is good.

No worries bro. I had an accident in July ( bumper kena respary) , CS2 gives a free re coat on my bumper. And 3 years warranty still applicable.

 

For any coating , i think minimal maintenance is still needed. Just my opinion. Enjoy your new ride !!

Share this post


Link to post
Share on other sites

No worries bro. I had an accident in July ( bumper kena respary) , CS2 gives a free re coat on my bumper. And 3 years warranty still applicable.

 

For any coating , i think minimal maintenance is still needed. Just my opinion. Enjoy your new ride !!

Thanks Kasiao.

Share this post


Link to post
Share on other sites

Couldn't get them enabled...

 

Seems like they need access to data service but no guide how to set that..

I'm going to check with the SE on this. 

Share this post


Link to post
Share on other sites

I'm going to check with the SE on this. 

OK. SE replied that this feature is not available yet and will advise us when it is available.

Share this post


Link to post
Share on other sites

does u guys organise road trip up north???

We are planning to in Nov. still gathering pple. 

Share this post


Link to post
Share on other sites

6 months n still very seldom seen on the roads! Just that blue hatch n white sedan...

Share this post


Link to post
Share on other sites

6 months n still very seldom seen on the roads! Just that blue hatch n white sedan...

Have la.

 

I saw a brown one just days ago.

↡ Advertisement

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×