Jump to content

Recommended Posts

Hey guy I got myself a new Honda fit, just 2 month my dashboard pop out handbrake sign, abs, power steering and anti skid icon, worse still is that my push start having a issue with a key icon, what could have the problem thank you

↡ Advertisement

Share this post


Link to post
Share on other sites

Hey guy I got myself a new Honda fit, just 2 month my dashboard pop out handbrake sign, abs, power steering and anti skid icon, worse still is that my push start having a issue with a key icon, what could have the problem thank you

I'm taking a guess here, Low Battery on your wireless Key fob?

Share this post


Link to post
Share on other sites

I also not sure, could not be 2 month only problem start?

Share this post


Link to post
Share on other sites

Hey guy I got myself a new Honda fit, just 2 month my dashboard pop out handbrake sign, abs, power steering and anti skid icon, worse still is that my push start having a issue with a key icon, what could have the problem thank you

 

 

yours is the new GK5? or the old fit model?

Share this post


Link to post
Share on other sites

W/o a diagnostic tool to see what are the error codes it's no point talking.

 

If really new car just go back workshop for warranty.

↡ Advertisement

Share this post


Link to post
Share on other sites

yours is the new GK5? or the old fit model?

GK3

Share this post


Link to post
Share on other sites

GK3

 

 

check your brake oil fluid level and also your abs sensors. could be these 2 things causing the brake light icon light up. get it check asap and dont delay further as brakes are the most important.

Share this post


Link to post
Share on other sites

Posted (edited)

Hey guy I got myself a new Honda fit, just 2 month my dashboard pop out handbrake sign, abs, power steering and anti skid icon, worse still is that my push start having a issue with a key icon, what could have the problem thank you

Yours is AD or PI car?

 

AD - go back and ask for warranty help

 

PI - good luck. Some reputable ones will still honour. If not restricted to particular workshops go to a third party workshop of your choice and get the fault diagnosed. Common garden Honda like this shouldn't be too ex to fix.

 

(We had a Honda Jazz before - Kah Motors used to bring in the Jazz but the Fit used to be strictly PI. Not sure whether this has changed now).

Edited by Turboflat4

Share this post


Link to post
Share on other sites

I'm taking a guess here, Low Battery on your wireless Key fob?

It could be the battery or alternator also.

Share this post


Link to post
Share on other sites

It reads like the car has been abused by a new inexperienced driver.

 

If driver is an experienced one, I suspect the ECU has a problem.

Share this post


Link to post
Share on other sites

It reads like the car has been abused by a new inexperienced driver.

 

If driver is an experienced one, I suspect the ECU has a problem.

My car is totally stock how to abuse it? I didn't add turbo etc...

Share this post


Link to post
Share on other sites

My car is totally stock how to abuse it? I didn't add turbo etc...

why not send back to agent? If it is a PI car, still can send to a workshop to dump the ODB code to see what is the cause. Though it may seem many errors, it is likely just one root cause.

Share this post


Link to post
Share on other sites

think this should be easy for the workshop to check w the diagnostic tool. Just go back to PI workshop to settle

↡ Advertisement

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×