Jump to content
rickylah

Pioneer z9250bt keep losing GPS after sometimes.

Recommended Posts

1st Gear

Anyone had issue with gps? Connected to AA. 

Sometimes after driving a while, abt the 20min mark, HU map will lose its GPS and go crazy. Same for both waze and Google map.

If I unplug and use my phone map, it works fine with correct location. Plug back to AA, Hu go crazy with location again. 

Fix:

Restart phone n connect back doesn't help. 

Restart car will help. But driving half way I also can't find a place to restart my car. 

Abit hard to demo this to shop i buy from, unless I wait for HU gps to go crazy then quickly drive down to show them. 

↡ Advertisement
  • Praise 1

Share this post


Link to post
Share on other sites
Moderator
21 minutes ago, rickylah said:

Anyone had issue with gps? Connected to AA. 

Sometimes after driving a while, abt the 20min mark, HU map will lose its GPS and go crazy. Same for both waze and Google map.

If I unplug and use my phone map, it works fine with correct location. Plug back to AA, Hu go crazy with location again. 

Fix:

Restart phone n connect back doesn't help. 

Restart car will help. But driving half way I also can't find a place to restart my car. 

Abit hard to demo this to shop i buy from, unless I wait for HU gps to go crazy then quickly drive down to show them. 

Is there a firmware update? Maybe need to do an update to the headunit.

Share this post


Link to post
Share on other sites
1st Gear
15 minutes ago, kobayashiGT said:

Is there a firmware update? Maybe need to do an update to the headunit.

@kobayashiGT 

No update available looking at pioneer website. And tmd just see the warranty just pass. Bought last year Feb. Lol. 

Thinking if GPS problem come again, should go direct to pioneer service Centre? Or the Audioshop? 

  • Haha! 1

Share this post


Link to post
Share on other sites
Moderator
1 hour ago, rickylah said:

@kobayashiGT 

No update available looking at pioneer website. And tmd just see the warranty just pass. Bought last year Feb. Lol. 

Thinking if GPS problem come again, should go direct to pioneer service Centre? Or the Audioshop? 

base on my suggestion (not experience because I own a sony headunit) I think if you go Pioneer, they will ask you go your audioshop. If you go your audioshop, they will ask you to upgrade.

You got try your wife android phone also?

Maybe is you need to change phone? hahah. 🤣

Share this post


Link to post
Share on other sites
1st Gear

i tap tap the gps after off my car. now working fine so far. i remember it always work ok for a while when i tap that gps antenna... lol.

if problem is the phone gps, why once unplugged, my phone showing the correct location? i think certain HU, once plug in to AA, it will only use the HU GPS antenna. 

 

and yes, the gps anthenna comes with the HU and installed together. Actually gps antenna spoilt, it doesnt cost much. Online is only selling around $30, but dunno how the audioshop will charge. 

  • Haha! 1

Share this post


Link to post
Share on other sites
Moderator
10 hours ago, rickylah said:

i tap tap the gps after off my car. now working fine so far. i remember it always work ok for a while when i tap that gps antenna... lol.

if problem is the phone gps, why once unplugged, my phone showing the correct location? i think certain HU, once plug in to AA, it will only use the HU GPS antenna. 

 

and yes, the gps anthenna comes with the HU and installed together. Actually gps antenna spoilt, it doesnt cost much. Online is only selling around $30, but dunno how the audioshop will charge. 

Change wire only, cannot charge much also lah. hahah

Share this post


Link to post
Share on other sites

1st Gear

ok discover a article that teaches how to solve this issue.

So far been working fine. 

just go reset 3d calibration. no idea what it is. but after reset, gps has been accurate and even losing signal in high rise area, once clear the gps signal comes back automatically, not stuck there. 

  • Praise 1

Share this post


Link to post
Share on other sites
1st Gear

Damn jinx. Say OK only gps keep losing location again. Nb. 

IMG_20210408_131122_BURST001_COVER.jpg

Share this post


Link to post
Share on other sites
4th Gear

@rickylah My understanding is , if using AA the phone itself is a gps.

It shouldn't need a gps from HU. U should try re-install AA , and change to a new original charging cable.

Share this post


Link to post
Share on other sites
1st Gear

My Aa not connected via cable. Wireless. Aa can't be install or uninstall. It's all build in to the latest android version. 

 

Anyway I have unplug the GPS antenna from the headunit and now AA gps is working fine via phone GPS

I believe antenna is faulty, and if it's connected, the Hu will always use the connect GPS instead of using my phone GPS

The cb audio shop has been so helpful only able to say phone spoil, only Samsung is stable. Pui. 

Share this post


Link to post
Share on other sites

Unplugged the antenna and gps still working well.

Definitely something to do with hu antenna, or antenna connector or something. 

 

↡ Advertisement

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×