Jump to content
Lala81

Urgent - battery or other problem?

Recommended Posts

Hypersonic (edited)

Eh guys. Stuck at yishun Central carpark. 

Is this a starter problem? 

Not a battery problem right? 

 

 

Edited by Lala81
↡ Advertisement
  • Praise 1

Share this post


Link to post
Share on other sites
Supersonic

Most likely it's the battery. Any voltage reader like those plug into ciggy lighter port? 

Share this post


Link to post
Share on other sites
Hypersonic (edited)

My battery died on me few times. Not like this leh. 

Nevermind. I call those car towing services. Think something faulty with the starter. Probably just need to be jump started. 

Haha noob at this. 

Edited by Lala81

Share this post


Link to post
Share on other sites
Supercharged
7 minutes ago, Lala81 said:

Eh guys. Stuck at yishun Central carpark. 

Is this a starter problem? But my sparkplug are less than 30k old only. 

Not a battery problem right? 

 

 

Get someone to jump start your car and try.

Could happen when CCA is really too low even to trigger the starter to crank

  • Praise 1

Share this post


Link to post
Share on other sites
Twincharged (edited)

Likely battery. 

Starter it won't has response at all.

 

Edited by Kopites
  • Praise 1

Share this post


Link to post
Share on other sites
Hypersonic

Somehow car managed to start up like one out of hundred attempts. Driving to workshop 

  • Praise 5

Share this post


Link to post
Share on other sites

Actually, looks like battery conk out to me. Had that before, no warning, one fine day dashboard lights flicker when starting the car, couldnt start,  when try to restart again, dashboard lights went dead.

  • Praise 3

Share this post


Link to post
Share on other sites

Supersonic

I occasionally check battery health with this type...not 100% accurate but you know it's an early warning if it falls to below 12 before crank. 

IMG_20211112_084818.jpg

  • Praise 2

Share this post


Link to post
Share on other sites
Supersonic (edited)

Battery most likely has drop below the 12V. 

After jump start you have to keep the engine running until you reach the battery shop.

Do you keep your camera running on the car battery? Stop doing that. 

Edited by Watwheels
  • Praise 3

Share this post


Link to post
Share on other sites
Twincharged
2 minutes ago, mersaylee said:

I occasionally check battery health with this type...not 100% accurate but you know it's an early warning if it falls to below 12 before crank. 

IMG_20211112_084818.jpg

Good enough.  Hey but 13.7v ? Your engine was running idel when taking this reading ? 

Share this post


Link to post
Share on other sites
Supersonic
Just now, Ct3833 said:

Good enough.  Hey but 13.7v ? Your engine was running idel when taking this reading ? 

Yup. After 4 days of wasted coe ...13.7 not bad liao 😅

12.2 without crank 

  • Praise 1

Share this post


Link to post
Share on other sites
Twincharged (edited)
3 minutes ago, mersaylee said:

Yup. After 4 days of wasted coe ...13.7 not bad liao 😅

12.2 without crank 

Ah so I guess was correct, idle 12.2v is still good for a few days of resting.  

@Lala81's problem is likely starter, it spins but the gear did not engage the flywheel.

Edited by Ct3833
  • Praise 1

Share this post


Link to post
Share on other sites
Hypersonic

OK lah probably battery. But car also need to service so shun bian lol. 

  • Haha! 1

Share this post


Link to post
Share on other sites
Hypersonic
25 minutes ago, Jtis said:

Actually, looks like battery conk out to me. Had that before, no warning, one fine day dashboard lights flicker when starting the car, couldnt start,  when try to restart again, dashboard lights went dead.

Yes that happened before to me. But this one haha u can still run radio and ac fan etc. 

Anyway probably battery lah. Just dropped off car at workshop. Shun bian do servicing

Share this post


Link to post
Share on other sites
Supersonic

should be battery. see the light flashing.

if u hear tac tac tac tac tac , sound.90% is battery issue, weak bat, or the connector loose.

starter sound, u press the button, either no sound, or u hear 1 tac only and no more respond. 

  • Praise 4

Share this post


Link to post
Share on other sites
Twincharged
4 minutes ago, Lala81 said:

Yes that happened before to me. But this one haha u can still run radio and ac fan etc. 

Anyway probably battery lah. Just dropped off car at workshop. Shun bian do servicing

Good luck.

Share this post


Link to post
Share on other sites
Supercharged
1 hour ago, Lala81 said:

Eh guys. Stuck at yishun Central carpark. 

Is this a starter problem? 

Not a battery problem right? 

 

 

Most probably battery issue. 
Discounting low fuel.
I experienced similar.


 

  • Praise 2

Share this post


Link to post
Share on other sites
Supersonic

Yeah sounds like battery bo lak. Nothing serious.

↡ Advertisement
  • Praise 3

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×