Jump to content

Recommended Posts

Posted (edited)

I have a weird AC Issue.

It doesn’t occur in Singapore as drive max is only 1 hour+

Last Long weekend I went to Malaysia and drove my vehicle for 5 6 hours non stop. At around 120 to 150km/h

Ac seems to not work after 3 4 hours of driving and was blowing out not so cold air. Front driver seat was fine but passenger is suffering.

Upon reaching Singapore. Speed was reduced to 90 100km/h. AC start to blow out freezing cold air again.

Temp gauge was half way point which is normal. Coolant EO all in its reasonable limit

At the point of time. NSHW outside temperature is about 38 to 40c range

Edited by Lightsabre
↡ Advertisement

Share this post


Link to post
Share on other sites

fresh or circulation mode

 

Share this post


Link to post
Share on other sites

Sound eerie esp when it is 7th month now.. Hahaha, just joking.

 

My guess is that the temp of coolant is too high for the radiator to cool it down after prolong high speed driving. Quite common.

Share this post


Link to post
Share on other sites

A lack of refrigerant.

You should get it check for leaks. If no leak then flush out the old and replenish the refrigerant.

Share this post


Link to post
Share on other sites
Posted (edited)

Sound eerie esp when it is 7th month now.. Hahaha, just joking.

 

My guess is that the temp of coolant is too high for the radiator to cool it down after prolong high speed driving. Quite common.

But the C And H needle did not move at all. Is it normal? All the way at half way point Edited by Goldenvodka
↡ Advertisement

Share this post


Link to post
Share on other sites
Posted (edited)

i would think is your radiator and condensor issue. as they age the fins maybe clog with dirt and dust and probably oil causing the optimal efficency of the radiator and condensors.

 

this is normal i guess as the fins and coils inside cannot disperse the heat properly hence is hot. travelling at 120-150kn/hr does helps the colling down of engine but likely cause is still narrow down to radiator and condenser aging.

 

moreover AC system also is linked to both radiator and condensor as part of one system.

 

just my 2 cents thoughts.

Edited by StreamRSZ

Share this post


Link to post
Share on other sites

Is the volume or air coming out still the same? Then it isn’t a frozen evaporator. Then likely compressor issue or the compressor clutch not engaging at higher rpm.

Share this post


Link to post
Share on other sites

Posted (edited)

Is the volume or air coming out still the same? Then it isnât a frozen evaporator. Then likely compressor issue or the compressor clutch not engaging at higher rpm.

Did not feel any difference in air flow.

I Guess for the time being just live with it. No point changing the compressor at this moment

 

Did a small test in the carpark. When vehicle is idling. Ac works fine with compressor engaged and fan spinning normally

Edited by Goldenvodka

Share this post


Link to post
Share on other sites

At the point of time. NSHW outside temperature is about 38 to 40c range

Outside temperature so high? Doesn’t sound right. You may have a faulty thermostat.

Share this post


Link to post
Share on other sites
Posted (edited)

Did not feel any difference in air flow.

I Guess for the time being just live with it. No point changing the compressor at this moment

 

Did a small test in the carpark. When vehicle is idling. Ac works fine with compressor engaged and fan spinning normally

I think it is likely the compressor too. if you dont go NSHW or long duration driving too often, I dont think you will face the problem again. Next time if you fcce the problem again, you may want to find a rest point to let the compressor cool down for a while before you drive on and see if it helps improve the situation. Edited by Ct3833

Share this post


Link to post
Share on other sites

Can it be engine heat is too strong causing air conditioning is not performing normally?

Share this post


Link to post
Share on other sites

Can it be engine heat is too strong causing air conditioning is not performing normally?

 

 

like what i mentioned, the issue could be your radiator and condensor. heat cannot properly escape due to aging radiator and condensor.

Share this post


Link to post
Share on other sites
Posted (edited)

like what i mentioned, the issue could be your radiator and condensor. heat cannot properly escape due to aging radiator and condensor.

Eh? How can it be? Isn’t the airflow at 140kmh higher than 90kmh?

 

Pretty sure it’s compressor and gas related as the rpm at 140kmh is probably at least 4k vs 3k or less at 90kmh. The compressor used in the swift is clutch driven and not a variable displacement one.

Edited by Mkl22
  • Praise 1

Share this post


Link to post
Share on other sites
Posted (edited)

Eh? How can it be? Isn’t the airflow at 140kmh higher than 90kmh?

 

Pretty sure it’s compressor and gas related as the rpm at 140kmh is probably at least 4k vs 3k or less at 90kmh. The compressor used in the swift is clutch driven and not a variable displacement one.

 

maybe you are right also. but anyway if you dont often msia than just live with it. by right at 140km/hr engine should also be cool enough to cool down engine and also coolant.

 

TS can send to workshop to check on gas level. if gas level is not at the normal range than could be like what you say compressor issue.

 

But if the gas level is at the normal range than it could likely be something else as i mentioned.

Edited by StreamRSZ

Share this post


Link to post
Share on other sites

Frankly asking here also make you confused with all the theories.

 

Bring to a aircon workshop better.

 

But since it’s working well here, just leave it.

Share this post


Link to post
Share on other sites

Can it be engine heat is too strong causing air conditioning is not performing normally?

Cannot be.

Share this post


Link to post
Share on other sites

85% of the time, air con issues are due to a worn out compressor. For compressors, make sure to always get brand new and never salvaged or reconditioned parts.

Share this post


Link to post
Share on other sites

85% of the time, air con issues are due to a worn out compressor. For compressors, make sure to always get brand new and never salvaged or reconditioned parts.

I think you are exaggerating la. Maybe 50% of the time. There’s so many other components that make up the aircon system. Condenser, cooling coil, etc.
↡ Advertisement

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×